ImportedInstanceId Property


The ElementId of the imported instance that represents the imported object(s) after a successful import. It could be used for further manipulation of that instance.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2010

Syntax

C#
public ElementId ImportedInstanceId { get; }
Visual Basic
Public ReadOnly Property ImportedInstanceId As ElementId
	Get
Visual C++
public:
property ElementId^ ImportedInstanceId {
	ElementId^ get ();
}

Remarks

The value could be InvalidElementId for some type of import formats, such as GBXML and Inventor files.

See Also