GetRefPoint Method


Returns the physical location of the reference point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2016

Syntax

C#
public XYZ GetRefPoint(
	int index
)
Visual Basic
Public Function GetRefPoint ( _
	index As Integer _
) As XYZ
Visual C++
public:
XYZ^ GetRefPoint(
	int index
)

Parameters

index
Type: System Int32
The index of the point to return.

Remarks

The index should be between 0 and less than NumRefPoints.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Thrown when index is out of range.

See Also