SetColoredSurfaceSettings Method


Set colored surface settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public void SetColoredSurfaceSettings(
	AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings
)
Visual Basic
Public Sub SetColoredSurfaceSettings ( _
	coloredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings _
)
Visual C++
public:
void SetColoredSurfaceSettings(
	AnalysisDisplayColoredSurfaceSettings^ coloredSurfaceSettings
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException colored surface settings were not created with the object.

See Also