OpeningTime Property


The opening time of the building type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public string OpeningTime { get; set; }
Visual Basic
Public Property OpeningTime As String
	Get
	Set
Visual C++
public:
property String^ OpeningTime {
	String^ get ();
	void set (String^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: It is not a valid time, can be something like "16:30" or "4:30 PM".
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also