AddinFolder Property


The full path to the Revit Macros module.

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public string AddinFolder { get; }
Visual Basic
Public ReadOnly Property AddinFolder As String
	Get
Visual C++
public:
virtual property String^ AddinFolder {
	String^ get () sealed;
}

Implements

IEntryPoint AddinFolder

Remarks

This path should be used instead of the .NET GetExecutingAssembly() result, because the Macros module is loaded in such a way to make that result unreliable.

See Also