Flag indicates whether curves are valid to use as base lines for winder path.
Namespace:
Autodesk.Revit.DB.Architecture
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Success | Indicates curves are valid to use as path base lines for winder run. This is only one flag indicates curves are fine to use as winder path. |
NumberOutOfRange | The curves number is not 2 or 3. |
Unbound | Curve is not bound. |
Noncontinuous | The curves are not continuous in one loop. |
NotOpenLoop | The curves are not in one open loop. |
TooShort | Curve length is too short. |
ColinearOrOverlap | Two curves are collinear or overlap. |
SelfIntersect | The first curve intersect with third curve. |
InvalidCurveType | Curve is not line. |
NotSupported | This path(for zigzag winder) is not supported yet |