IsValidApprovalTypeName Method


Verifies if the provided approval name is unique in the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2017

Syntax

C#
public static bool IsValidApprovalTypeName(
	Document doc,
	string name
)
Visual Basic
Public Shared Function IsValidApprovalTypeName ( _
	doc As Document, _
	name As String _
) As Boolean
Visual C++
public:
static bool IsValidApprovalTypeName(
	Document^ doc, 
	String^ name
)

Parameters

doc
Type: Autodesk.Revit.DB Document
name
Type: System String

Return Value

True if approval type name is unique.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also