GetLocalCoordinateSystem Method (XYZ)


Gets the local coordinate system (LCS) reflects analytical model orientation at the specified point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2013

Syntax

C#
public Transform GetLocalCoordinateSystem(
	XYZ point
)
Visual Basic
Public Function GetLocalCoordinateSystem ( _
	point As XYZ _
) As Transform
Visual C++
public:
Transform^ GetLocalCoordinateSystem(
	XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB XYZ
The point on the analytical model surface element.

Return Value

Transformation matrix.
  • x - longitudinal axis,
  • y - transversal, section - horizontal, strong axis,
  • z - transversal, section - vertical, weak axis,
  • origin - base point of LCS.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Thrown when called with point that not lie on the analytical model surface element.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also