GetClosedShell Method


Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public IList<Polyloop> GetClosedShell()
Visual Basic
Public Function GetClosedShell As IList(Of Polyloop)
Visual C++
public:
IList<Polyloop^>^ GetClosedShell()

Return Value

the collection of polygons that form a closed shell.

See Also