BuildingTypeId Property


The building type element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2012

Syntax

C#
public ElementId BuildingTypeId { get; set; }
Visual Basic
Public Property BuildingTypeId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ BuildingTypeId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also