FenceType Property


Type of diagram fence visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public AnalysisDisplayStyleDiagramFenceType FenceType { get; set; }
Visual Basic
Public Property FenceType As AnalysisDisplayStyleDiagramFenceType
	Get
	Set
Visual C++
public:
property AnalysisDisplayStyleDiagramFenceType FenceType {
	AnalysisDisplayStyleDiagramFenceType get ();
	void set (AnalysisDisplayStyleDiagramFenceType value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also