Namespace:
Autodesk.Revit.Creation
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- location
-
Type:
Autodesk.Revit.DB
XYZ
The physical location where the instance is to be placed.
- symbol
-
Type:
Autodesk.Revit.DB
FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
- host
-
Type:
Autodesk.Revit.DB
Element
The object into which the FamilyInstance is to be inserted, often known as the host.
- structuralType
-
Type:
Autodesk.Revit.DB.Structure
StructuralType
If structural then specify the type of the component.
Return Value
If creation was successful then an instance to the new object is returned, otherwise a null reference ( Nothing in Visual Basic) .Remarks
The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.
The host object must be one that supports insertion of instances otherwise this method will fail.
Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.
Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.
Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.
Examples
Wall CreateWallWithWindows(Autodesk.Revit.DB.Document document, Level level)
{
// Create a new wall
// Build a location line for the wall creation
XYZ start = new XYZ(0, 0, 0);
XYZ end = new XYZ(10, 10, 0);
Line wallLine = Line.CreateBound(start, end);
// Create a wall using the location line
Wall newWall = Wall.Create(document, wallLine, level.Id, true);
// Find a Window type for the new windows
FilteredElementCollector winCollector = new FilteredElementCollector(document);
IList<Element> windowTypes = winCollector.OfCategory(BuiltInCategory.OST_Windows).WhereElementIsElementType().ToElements();
FamilySymbol winType = windowTypes.First() as FamilySymbol;
// put 3 windows in the wall
double x = 2, y = 2, z = 2;
for (int i = 0; i < 3; i++)
{
XYZ location = new XYZ(x, y, z);
FamilyInstance instance = document.Create.NewFamilyInstance(location, winType, newWall, StructuralType.NonStructural);
x += 3;
y += 3;
}
return newWall;
}
Private Function CreateWallWithWindows(document As Autodesk.Revit.DB.Document, level As Level) As Wall
' Create a new wall
' Build a location line for the wall creation
Dim start As New XYZ(0, 0, 0)
Dim [end] As New XYZ(10, 10, 0)
Dim wallLine As Line = Line.CreateBound(start, [end])
' Create a wall using the location line
Dim newWall As Wall = Wall.Create(document, wallLine, level.Id, True)
' Find a Window type for the new windows
Dim winCollector As New FilteredElementCollector(document)
Dim windowTypes As IList(Of Element) = winCollector.OfCategory(BuiltInCategory.OST_Windows).WhereElementIsElementType().ToElements()
Dim winType As FamilySymbol = TryCast(windowTypes.First(), FamilySymbol)
' put 3 windows in the wall
Dim x As Double = 2, y As Double = 2, z As Double = 2
For i As Integer = 0 To 2
Dim location As New XYZ(x, y, z)
Dim instance As FamilyInstance = document.Create.NewFamilyInstance(location, winType, newWall, StructuralType.NonStructural)
x += 3
y += 3
Next
Return newWall
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if The symbol is not active. |