AddConstraintArcLength Method


Specify a parameter to drive the arc length of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2009

Syntax

C#
public void AddConstraintArcLength(
	ElementId paramId
)
Visual Basic
Public Sub AddConstraintArcLength ( _
	paramId As ElementId _
)
Visual C++
public:
void AddConstraintArcLength(
	ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also