FilterCategoryRule Constructor


Constructs a new instance of FilterCategoryRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public FilterCategoryRule(
	ICollection<ElementId> categories
)
Visual Basic
Public Sub New ( _
	categories As ICollection(Of ElementId) _
)
Visual C++
public:
FilterCategoryRule(
	ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic ICollection ElementId
The set of categories.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also