GetWidth Method (Int32)


Computes the width of the envelope (2d bounding box) of the specified region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public double GetWidth(
	int regionId
)
Visual Basic
Public Function GetWidth ( _
	regionId As Integer _
) As Double
Visual C++
public:
double GetWidth(
	int regionId
)

Parameters

regionId
Type: System Int32
The id of a region in this vertically compound structure.

Return Value

The width of the envelope (2d bounding box) of the region.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException It is not a valid region id.
Autodesk.Revit.Exceptions InvalidOperationException This operation is valid only for vertically compound structures.

See Also