Points Property


The points of the flex duct.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public IList<XYZ> Points { get; set; }
Visual Basic
Public Property Points As IList(Of XYZ)
	Get
	Set
Visual C++
public:
property IList<XYZ^>^ Points {
	IList<XYZ^>^ get ();
	void set (IList<XYZ^>^ value);
}

Remarks

This property is used to retrieve the points of flex duct, including the end points. If the end points are changed, the connection will be maintained by Revit automatically. The set operation will fail if the modification makes the connection invalid.

See Also