IsOverriddenParameterModifiable Method


Checks if overridden parameter is modifiable.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public bool IsOverriddenParameterModifiable(
	ElementId paramId
)
Visual Basic
Public Function IsOverriddenParameterModifiable ( _
	paramId As ElementId _
) As Boolean
Visual C++
public:
bool IsOverriddenParameterModifiable(
	ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB ElementId
Overridden parameter id

Return Value

True if the parameter is modifiable, false if the parameter is readonly.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException paramId has no override
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also