Converts a collection of duct placeholder elements into duct elements.
Namespace:
Autodesk.Revit.DB.Mechanical
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The document.
- placeholderIds
-
Type:
System.Collections.Generic
ICollection
ElementId
A collection of element IDs of duct placeholders.
Return Value
A collection of element IDs of ducts and fittings.Remarks
Once conversion succeeds, the duct placeholder elements are deleted.
The new duct and fitting elements are created and connections are established.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given element id set is empty. -or- The given element IDs (placeholderIds) are not duct placeholders. -or- The elements belong to different types of system. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |