CADObjectUniqueId Property


The unique id of the originating CAD object (model element) associated with this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public string CADObjectUniqueId { get; }
Visual Basic
Public ReadOnly Property CADObjectUniqueId As String
	Get
Visual C++
public:
property String^ CADObjectUniqueId {
	String^ get ();
}

Remarks

This id can be passed to obtain the element from Document.Element[string] property, but any element obtained through this method may no longer point to a valid or up-to-date model element. The originating CAD object is only accurate and up-to-date at the time of creation of the energy model.

See Also