SetDeformedShapeSettings Method


Set deformed shape settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public void SetDeformedShapeSettings(
	AnalysisDisplayDeformedShapeSettings deformedShapeSettings
)
Visual Basic
Public Sub SetDeformedShapeSettings ( _
	deformedShapeSettings As AnalysisDisplayDeformedShapeSettings _
)
Visual C++
public:
void SetDeformedShapeSettings(
	AnalysisDisplayDeformedShapeSettings^ deformedShapeSettings
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException Deformed shape settings were not created with the object.

See Also