SetName Method


Sets the name for the DirectShape element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public void SetName(
	string name
)
Visual Basic
Public Sub SetName ( _
	name As String _
)
Visual C++
public:
void SetName(
	String^ name
)

Parameters

name
Type: System String
The name.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also