PathEnd Property


The end point of the path. The Z coordinate is ignored.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since: 2020

Syntax

C#
public XYZ PathEnd { get; set; }
Visual Basic
Public Property PathEnd As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ PathEnd {
	XYZ^ get ();
	void set (XYZ^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException When setting this property: The Path of Travel has waypoints set.

See Also