SpaceFilter Class


A filter used to match spaces.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class SpaceFilter : ElementSlowFilter
Visual Basic
Public Class SpaceFilter _
	Inherits ElementSlowFilter
Visual C++
public ref class SpaceFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

See Also