AddOverride Method (ElementId, String)


Adds an override for the given parameter as its value will be displayed for the Rebar Container element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public void AddOverride(
	ElementId paramId,
	string value
)
Visual Basic
Public Sub AddOverride ( _
	paramId As ElementId, _
	value As String _
)
Visual C++
public:
void AddOverride(
	ElementId^ paramId, 
	String^ value
)

Parameters

paramId
Type: Autodesk.Revit.DB ElementId
The id of the parameter
value
Type: System String
The override value of the parameter.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException paramId is not the id of a parameter in the current document, or its value type is not sring. -or- paramId is not a Rebar Container parameter
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also