Sign Property


When the sign is 1, the Direction is rotated clockwise by the angle's value. When -1, the Direction is rotated counter-clockwise.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public int Sign { get; set; }
Visual Basic
Public Property Sign As Integer
	Get
	Set
Visual C++
public:
property int Sign {
	int get ();
	void set (int value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: sign is not 1 or -1.
Autodesk.Revit.Exceptions DisabledDisciplineException When setting this property: None of the following disciplines is enabled: Structural.

See Also