GetOpenings Method


Retrieves Analytical Surface Openings Identifiers valid to be used in showOpening/hideOpening functions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public void GetOpenings(
	out ICollection<ElementId> openingsIds
)
Visual Basic
Public Sub GetOpenings ( _
	<OutAttribute> ByRef openingsIds As ICollection(Of ElementId) _
)
Visual C++
public:
void GetOpenings(
	[OutAttribute] ICollection<ElementId^>^% openingsIds
)

Parameters

openingsIds
Type: System.Collections.Generic ICollection ElementId %
Set of openings Identifiers in Analytical Surface Element which are valid for hide.

See Also