Move the element within the project by a specified vector.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- translation
-
Type:
Autodesk.Revit.DB
XYZ
The vector by which the element is to be moved.
Return Value
If the element is moved successfully then the method return True, otherwise False.Remarks
The move method is used to move an element within the project. Other elements may also be
moved when this element is moved, for example: if the element is wall and it contains windows, the
windows will also be moved.
Examples
Copy
C#
bool MoveUsingLocationCurve(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
LocationCurve wallLine = wall.Location as LocationCurve;
XYZ translationVec = new XYZ(10, 20, 0);
return (wallLine.Move(translationVec));
}
Copy
VB.NET
Private Function MoveUsingLocationCurve(application As Autodesk.Revit.ApplicationServices.Application, wall As Wall) As Boolean
Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
Dim translationVec As New XYZ(10, 20, 0)
Return (wallLine.Move(translationVec))
End Function