GetPlane Method


Returns plane on which Analytical Model Surface Element is lying. Only planar surface elements are valid for this function.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public Plane GetPlane()
Visual Basic
Public Function GetPlane As Plane
Visual C++
public:
Plane^ GetPlane()

Return Value

Plane object on which Analytical Model is projected.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException This AnalyticalModelSurface is not a planar object.

See Also