RemoveCutBetweenSolids Method


Removes the solid-solid cut between the two elements if it exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public static void RemoveCutBetweenSolids(
	Document document,
	Element first,
	Element second
)
Visual Basic
Public Shared Sub RemoveCutBetweenSolids ( _
	document As Document, _
	first As Element, _
	second As Element _
)
Visual C++
public:
static void RemoveCutBetweenSolids(
	Document^ document, 
	Element^ first, 
	Element^ second
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document containing the two elements
first
Type: Autodesk.Revit.DB Element
The solid being cut or the cutting solid.
second
Type: Autodesk.Revit.DB Element
The solid being cut or the cutting solid.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also