RebarShapeDefinitionByArc Constructor (Document, RebarShapeDefinitionByArcType)


Create a non-spiral shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public RebarShapeDefinitionByArc(
	Document doc,
	RebarShapeDefinitionByArcType type
)
Visual Basic
Public Sub New ( _
	doc As Document, _
	type As RebarShapeDefinitionByArcType _
)
Visual C++
public:
RebarShapeDefinitionByArc(
	Document^ doc, 
	RebarShapeDefinitionByArcType type
)

Remarks

Replaces RebarShape.NewDefinitionByArc() from prior versions.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also