ElementSlowFilter Class


A base class for a type of filter that operates on expanded elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public class ElementSlowFilter : ElementFilter
Visual Basic
Public Class ElementSlowFilter _
	Inherits ElementFilter
Visual C++
public ref class ElementSlowFilter : public ElementFilter

Remarks

Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple slow filters with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded in order to evaluate against the criteria set by this filter.

Inheritance Hierarchy

See Also