Approximate Method


Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public void Approximate(
	bool enableApproximation
)
Visual Basic
Public Sub Approximate ( _
	enableApproximation As Boolean _
)
Visual C++
public:
void Approximate(
	bool enableApproximation
)

Parameters

enableApproximation
Type: System Boolean
Enable/disable approximated function.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions InvalidOperationException This AnalyticalModel does not support approximation.

See Also