GetCommonCoverType Method


If all exposed faces of the host have the same associated CoverType, return that CoverType; otherwise, return a null reference ( Nothing in Visual Basic) .

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2012

Syntax

C#
public RebarCoverType GetCommonCoverType()
Visual Basic
Public Function GetCommonCoverType As RebarCoverType
Visual C++
public:
RebarCoverType^ GetCommonCoverType()

Return Value

The common CoverType for all exposed faces, or a null reference ( Nothing in Visual Basic) if there are multiple CoverTypes.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also