GetAnalyticalSurfaces Method


Provides a way to access the collection of analytical surfaces for a space. Geometry data defining an analytical space volume. Through an analytical surface you can connect a source element with each polygon in a space. The analytical surfaces defines an enclosed volume bounded by the center plane of walls and the top plane of roofs and floors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public IList<EnergyAnalysisSurface> GetAnalyticalSurfaces()
Visual Basic
Public Function GetAnalyticalSurfaces As IList(Of EnergyAnalysisSurface)
Visual C++
public:
IList<EnergyAnalysisSurface^>^ GetAnalyticalSurfaces()

Return Value

the collection of analytical surfaces for a space.

See Also