GetExternalItems Method


Gets the collection of externally added items which should be shown in the Transfer Project Standards dialog as options.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2017.2

Syntax

C#
public IDictionary<Guid, string> GetExternalItems()
Visual Basic
Public Function GetExternalItems As IDictionary(Of Guid, String)
Visual C++
public:
IDictionary<Guid, String^>^ GetExternalItems()

Return Value

The external items which are displayed in the Transfer Project Standards UI. GUIDvalue is used to identify the external item string.

See Also