Sets the type of a resolution to be used to resolve the failure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- resolutionType
- Type: Autodesk.Revit.DB FailureResolutionType
The type of failure resolution to be used to resolve the failure.
Remarks
When FailuresAccessor is used to resolve failures, it will execute resolutions based on current resolution type. If no current resolution type is set, the default resolution type will be used. Setting is performed on the FailureMessageAccessor object itself, so if there are several accessors issued for the same FailureMessage, setting of the resolution type performed on one of them does not impact the others.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This FailureMessageAccessor has no resolution of resolutionType. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | This FailureMessageAccessor has not been properly initialized. -or- This FailureMessageAccessor does not have any resolutions. |