Formats a number with units into a string.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- units
- Type: Autodesk.Revit.DB Units
The units formatting settings, typically obtained from Document.GetUnits() .
- unitType
- Type: Autodesk.Revit.DB UnitType
The unit type of the value to format.
- value
- Type: System Double
The value to format, in Revit's internal units.
- forEditing
- Type: System Boolean
True if the formatting should be modified as necessary so that the formatted string can be successfully parsed, for example by suppressing digit grouping. False if unmodified settings should be used, suitable for display only.
Return Value
The formatted string.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | unitType is an invalid unit type. See UnitUtils.IsValidUnitType() and UnitUtils.GetValidUnitTypes(). -or- The given value for value is not finite |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |