Name Property


Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
	Set
Visual C++
public:
virtual property String^ Name {
	void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for GenericForm object, an InvalidOperationException will be thrown.

See Also