ArgumentException Class


The exception that is thrown when one of the arguments provided to a method is not valid.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
[SerializableAttribute]
public class ArgumentException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class ArgumentException _
	Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class ArgumentException : public ApplicationException

Remarks

This is the base class for exceptions that are thrown while validating the arguments to a function.

Inheritance Hierarchy

See Also