Room Property


The room in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public Room Room { get; }
Visual Basic
Public ReadOnly Property Room As Room
	Get
Visual C++
public:
property Room^ Room {
	Room^ get ();
}

Remarks

This property will be the first room encountered that contains the instance. If more than one room includes this point in its volume only the first one is returned. If no room is found that contains the instance, this property is a null reference ( Nothing in Visual Basic) . This property should not be used for door or window instances, which are placed on the boundary or between rooms. Use the FromRoom and ToRoom properties instead.

See Also