GetUnitGroup Method


Gets the unit group for a given unit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetUnitGroup(ForgeTypeId)` overload instead.")]
public static UnitGroup GetUnitGroup(
	UnitType unitType
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetUnitGroup(ForgeTypeId)` overload instead.")> _
Public Shared Function GetUnitGroup ( _
	unitType As UnitType _
) As UnitGroup
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetUnitGroup(ForgeTypeId)` overload instead.")]
public:
static UnitGroup GetUnitGroup(
	UnitType unitType
)

Parameters

unitType
Type: Autodesk.Revit.DB UnitType
The unit type.

Return Value

The unit group.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException unitType is an invalid unit type. See UnitUtils.IsValidUnitType() and UnitUtils.GetValidUnitTypes().
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also