Create Method


Creates a DirectShapeType element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015

Syntax

C#
public static DirectShapeType Create(
	Document document,
	string name,
	ElementId categoryId
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	name As String, _
	categoryId As ElementId _
) As DirectShapeType
Visual C++
public:
static DirectShapeType^ Create(
	Document^ document, 
	String^ name, 
	ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document that will contain the new element. Must be a project document.
name
Type: System String
Name of the DirectShapeType.
categoryId
Type: Autodesk.Revit.DB ElementId
Id of the category assigned to this DirectShapeType. Must be a valid category id.

Return Value

The new DirectShapeType.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException document is not a project document. -or- Document document may not contain DirectShape or DirectShapeType objects. -or- Element id categoryId may not be used as a DirectShape category.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also