CurveElement Class


Class representing curve elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public class CurveElement : Element
Visual Basic
Public Class CurveElement _
	Inherits Element
Visual C++
public ref class CurveElement : public Element

Remarks

As a base class of several specialized curved elements (such as ModelCurve, ModelLine, CurveByPoints, etc.) CurveElement exposes methods and properties of general use applicable to most kinds of curves.

Inheritance Hierarchy

See Also