IsValidFormatOptions Method


Checks whether a FormatOptions object is valid for the LabelType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017 Subscription Update

Syntax

C#
public bool IsValidFormatOptions()
Visual Basic
Public Function IsValidFormatOptions As Boolean
Visual C++
public:
bool IsValidFormatOptions()

Return Value

True if the FormatOptions object is valid, false otherwise.

Remarks

Only objects whose LabelType is LengthOfSegment or TotalLength can have FormatOptions assigned.

See Also