IsReadOnly Property


Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public override bool IsReadOnly { get; }
Visual Basic
Public Overrides ReadOnly Property IsReadOnly As Boolean
	Get
Visual C++
public:
virtual property bool IsReadOnly {
	bool get () override;
}

Field Value

If true, the object may not be modified. If false, the object's contents may be modified.

See Also