RegisterInterface Method


Registers a IExtElemChangeBeamSection

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2018

Syntax

C#
public static void RegisterInterface(
	IExtElemChangeBeamSection provider
)
Visual Basic
Public Shared Sub RegisterInterface ( _
	provider As IExtElemChangeBeamSection _
)
Visual C++
public:
static void RegisterInterface(
	IExtElemChangeBeamSection^ provider
)

Parameters

provider
Type: Autodesk.Revit.DB.Structure IExtElemChangeBeamSection
IExtElemChangeBeamSection to be registered.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The provider object is not valid.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException There is already registered Connections Provider.

See Also