Presets for given Analytical Projection. Combined with AnalyticalDirection, this abstracts
Analytical Projections for all Structural Elements
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Top | Vertically, on top of physical model. |
Center | Vertically, center of physical model. |
Bottom | Vertically, bottom of physical model. |
SideOne | Horizontally, corresponds to first side (e.g., interior). |
SideTwo | Horizontally, corresponds to second side (e.g., exterior). |
AutoDetect | Auto-detect projections for analytical model. |
Invalid | Set to a bad setting. Should only be set at this very rarely (i.e., at initial creation). |
SketchCurve | For sketch-based analytical models. |
DatumPlane | Use a Datum Plane for projection (e.g., Grid, Level). |
NotApplicable | None of the other projection types apply. |
Default | Element-specific default value. |
CenterOfCore | Center of wall core. |
LocationLine | Location Line. |
Varies | Projection types are different at each end. |