ExportObjectData Property


Whether to include properties associated with elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public bool ExportObjectData { get; set; }
Visual Basic
Public Property ExportObjectData As Boolean
	Get
	Set
Visual C++
public:
property bool ExportObjectData {
	bool get ();
	void set (bool value);
}

Remarks

ExportObjectData must be enabled (true) in order to also enable exporting rooms and areas (ExportingAreas). If ExportObjectData is disabled, the ExportingAreas property will be ignored.

See Also