Reloads the ImageType from a new image file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- imagePath
- Type: System String
A new path to an image file to load.
Remarks
If the image file contains multiple pages the first page will be loaded. If reload fails the currently loaded image will remain unchanged.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The provided path is not a local path. -or- imagePath is an empty string. -or- The file represented by imagePath is not a supported image file type. -or- The image file represented by imagePath is a password protected PDF file. -or- The image file represented by imagePath could not be read and may be corrupt. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions FileArgumentNotFoundException | The file represented by imagePath does not exist. |
Autodesk.Revit.Exceptions InvalidOperationException | This ImageType was not loaded from a file. |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document containing this ImageType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this ImageType is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document containing this ImageType has no open transaction. |
Autodesk.Revit.Exceptions OptionalFunctionalityNotAvailableException | The image file represented by imagePath is a PDF file but PDF import is not available in the installed Revit. |