Returns the vectors describing the curve at the specified parameter.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameter
-
Type:
System
Double
The parameter to be evaluated.
- normalized
-
Type:
System
Boolean
If false, param is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.
Return Value
The transformation containing the point on the curve, the tangent vector, derivative of tangent vector, and bi-normal vector.Remarks
The following is the meaning of the transformation members:
Origin is the point on the curve (equivalent to
Evaluate(Double, Boolean)
).BasisX is the tangent vector (the first derivative).BasisY is the second derivative. Note that for curves where this cannot be uniquely determined (e.g. lines), this will be a Zero vector.BasisZ is the bi-normal vector (tangent x normal). Note that for curves where normal cannot be uniquely determined (e.g. lines), this will be a Zero vector.
None of the vectors are normalized.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value for parameter is not finite |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The curve cannot be evaluated as normalized because it is unbound. -or- The parameter is not a valid value for normalized evaluation. |